freetz e trunk

Moderatore: phpBB Moderatori

Messaggioda pystik » mar mag 28, 2013 6:34 pm

salve ragazzi volevo chiedere se c'è qualcuno di voi che riesce ancora ad usare i vari freetz e freetz-trunk
io ho installato da poco e non riesco a completare il make:
punta su un sito ( per fare download ) che non esiste piu.....

Download failed - http://freetz.wirsind.info/FRITZ.Box_Fo ... 4.82.image -> error code 8
ERROR: Could not download Firmwareimage.
make: *** [dl/fw/FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image] Errore 3
Avatar utente
pystik
Advanced
Advanced
 
Messaggi: 252
Iscritto il: sab mag 02, 2009 3:49 pm
Ha ringraziato: 1 volta
Hai ringraziamenti: 0 volta

Messaggioda skizzo3000 » mar mag 28, 2013 7:24 pm

a me funziona l'ultimo trunk

Sk3
Avatar utente
skizzo3000
phpBB Moderator
phpBB Moderator
 
Messaggi: 4531
Iscritto il: sab lug 08, 2006 9:29 pm
Località: Padova
Ha ringraziato: 2 volte
Hai ringraziamenti: 63 volte

Messaggioda pystik » mar mag 28, 2013 9:13 pm

dopo aver installato il trunk mi da il seguente messaggio:
Makefile:132: *** Some build prerequisites are missing! Please install the missing packages before trying again. Arresto

ma non capisco quali sono i pacchetti da installare.... :( :(
Avatar utente
pystik
Advanced
Advanced
 
Messaggi: 252
Iscritto il: sab mag 02, 2009 3:49 pm
Ha ringraziato: 1 volta
Hai ringraziamenti: 0 volta

Messaggioda skizzo3000 » mar mag 28, 2013 10:08 pm

Tutti quelli elencati nella wiki di freetz.org
Avatar utente
skizzo3000
phpBB Moderator
phpBB Moderator
 
Messaggi: 4531
Iscritto il: sab lug 08, 2006 9:29 pm
Località: Padova
Ha ringraziato: 2 volte
Hai ringraziamenti: 63 volte

Messaggioda pystik » mar mag 28, 2013 10:47 pm

cioè questi:
http://freetz.org/wiki/packages

ma come si installano???? :o :o
Avatar utente
pystik
Advanced
Advanced
 
Messaggi: 252
Iscritto il: sab mag 02, 2009 3:49 pm
Ha ringraziato: 1 volta
Hai ringraziamenti: 0 volta

Messaggioda skizzo3000 » mer mag 29, 2013 12:10 pm

Ma no!! Quelli sono presenti nel freetz, sono quelli che si possono aggiungere nel fw!!.

I prerequisiti sono
http://freetz.org/wiki/help/howtos/comm ... gtenPakete

Sk3
Avatar utente
skizzo3000
phpBB Moderator
phpBB Moderator
 
Messaggi: 4531
Iscritto il: sab lug 08, 2006 9:29 pm
Località: Padova
Ha ringraziato: 2 volte
Hai ringraziamenti: 63 volte

Messaggioda pystik » mer mag 29, 2013 12:27 pm

grazie skizzo per la tua pazienza ; ma manca sempre 1:


gino@gino-laptop:~/freetz-trunk$ sudo apt-get -y install graphicsmagick subversion gcc g++ binutils autoconf automake automake1.9 automake1.8 libtool make bzip2 libncurses5-dev zlib1g-dev flex bison patch texinfo tofrodos gettext pkg-config jikes ecj-bootstrap fastjar realpath perl libstring-crc32-perl ruby ruby1.8 gawk python libusb-dev unzip xz-utils
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
subversion è già alla versione più recente.
gcc è già alla versione più recente.
g++ è già alla versione più recente.
binutils è già alla versione più recente.
autoconf è già alla versione più recente.
automake è già alla versione più recente.
automake1.9 è già alla versione più recente.
E: Impossibile trovare il pacchetto automake1.8

che balls........

p.s. per controllare i pacchetti installati su un firmware qual'è il comando???


p.s. 2
mancano anche altri 2 pacchetti:


gino@gino-laptop:~/freetz-trunk$ sudo apt-get -y install graphicsmagick subversion gcc g++ binutils autoconf automake automake1.9 libtool make bzip2 libncurses5-dev zlib1g-dev flex bison patch texinfo tofrodos gettext pkg-config jikes ecj fastjar realpath perl libstring-crc32-perl ruby ruby1.8 gawk python libusb-dev unzip intltool
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
subversion è già alla versione più recente.
gcc è già alla versione più recente.
g++ è già alla versione più recente.
binutils è già alla versione più recente.
autoconf è già alla versione più recente.
automake è già alla versione più recente.
automake1.9 è già alla versione più recente.
libtool è già alla versione più recente.
make è già alla versione più recente.
bzip2 è già alla versione più recente.
libncurses5-dev è già alla versione più recente.
zlib1g-dev è già alla versione più recente.
flex è già alla versione più recente.
bison è già alla versione più recente.
patch è già alla versione più recente.
texinfo è già alla versione più recente.
tofrodos è già alla versione più recente.
gettext è già alla versione più recente.
pkg-config è già alla versione più recente.
E: Impossibile trovare il pacchetto jikes
gino@gino-laptop:~/freetz-trunk$ sudo apt-get -y install libc6-dev-i386 lib32ncurses5-dev gcc-multilib
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
E: Impossibile trovare il pacchetto libc6-dev-i386
Avatar utente
pystik
Advanced
Advanced
 
Messaggi: 252
Iscritto il: sab mag 02, 2009 3:49 pm
Ha ringraziato: 1 volta
Hai ringraziamenti: 0 volta

Messaggioda skizzo3000 » mer mag 29, 2013 6:11 pm

che versione di ubuntu stai usando ?

se alcuni pakketti nn li trova nn importa


che errore hai durante il make ?

Sk3
Avatar utente
skizzo3000
phpBB Moderator
phpBB Moderator
 
Messaggi: 4531
Iscritto il: sab lug 08, 2006 9:29 pm
Località: Padova
Ha ringraziato: 2 volte
Hai ringraziamenti: 63 volte

Messaggioda pystik » mer mag 29, 2013 6:25 pm

si uso la 10.4
gli errori sono quelli riportati sopra
cmq ho anche il freetz 1.1.3 e 1.2 in pratica non nessuno dei 3 ( e tra l'altro anche su un altro computer) riesco a fare un make.
sono sconcertato

p.s. riporto tutto il processo magari si capisce meglio:

gino@gino-laptop:~$ cd freetz-1.1.3
gino@gino-laptop:~/freetz-1.1.3$ make
cp -a /home/gino/freetz-1.1.3/toolchain/build/gcc-4.2.1-uClibc-0.9.29/mipsel-linux-uclibc/mipsel-linux-uclibc/lib/libgcc_s* root/lib/
/home/gino/freetz-1.1.3/toolchain/target/bin/mipsel-linux-uclibc-strip --remove-section={.comment,.note,.pdr} root/lib/libgcc_s.so.1
STEP 0: DOWNLOAD
downloading firmware image

--2013-05-29 20:28:43-- ftp://ftp.avm.de/fritz.box/fritzbox.fon ... 4.82.image
=> "dl/fw/FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image"
Risoluzione di ftp.avm.de... 212.42.244.90
Connessione a ftp.avm.de|212.42.244.90|:21... connesso.
Accesso come utente anonymous ... Login eseguito!
==> SYST ... fatto. ==> PWD ... fatto.
==> TYPE I ... fatto. ==> CWD (1) /fritz.box/fritzbox.fon_wlan_7170/firmware/english/annex_b ... fatto.
==> SIZE FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image ... 7434240
==> PASV ... fatto. ==> RETR FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image ... fatto.
Lunghezza: 7434240 (7,1M) (non autorevole)

100%[======================================>] 7.434.240 586K/s in 14s

2013-05-29 20:28:59 (526 KB/s) - "dl/fw/FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image" salvato [7434240]

Download succeeded - ftp://ftp.avm.de/fritz.box/fritzbox.fon ... 4.82.image -> saved to folder dl/fw
MD5 mismatch for dl/fw/FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image: 978b2f6ae06ddb61d6626b80f6feb09d 642eea123e85d1f6cde4481c6d8bd9a1

--2013-05-29 20:28:59-- http://download.avm.de/fritz.box/fritzb ... 4.82.image
Risoluzione di download.avm.de... 212.42.244.7
Connessione a download.avm.de|212.42.244.7|:80... connesso.
HTTP richiesta inviata, in attesa di risposta... 200 OK
Lunghezza: 7434240 (7,1M) [application/x-image]
Salvataggio in: "dl/fw/FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image"

100%[======================================>] 7.434.240 775K/s in 12s

2013-05-29 20:29:11 (597 KB/s) - "dl/fw/FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image" salvato [7434240/7434240]

Download succeeded - http://download.avm.de/fritz.box/fritzb ... 4.82.image -> saved to folder dl/fw
MD5 mismatch for dl/fw/FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image: 978b2f6ae06ddb61d6626b80f6feb09d 642eea123e85d1f6cde4481c6d8bd9a1

--2013-05-29 20:29:11-- http://freetz.3dfxatwork.de/FRITZ.Box_F ... 4.82.image
Risoluzione di freetz.3dfxatwork.de... 85.214.81.232, 2a01:238:4362:b900:fc60:1b77:4435:1ba9
Connessione a freetz.3dfxatwork.de|85.214.81.232|:80... connesso.
HTTP richiesta inviata, in attesa di risposta... 404 Not Found
2013-05-29 20:29:11 ERRORE 404: Not Found.

Download failed - http://freetz.3dfxatwork.de/FRITZ.Box_F ... 4.82.image -> error code 8

--2013-05-29 20:29:11-- http://freetz.wirsind.info/FRITZ.Box_Fo ... 4.82.image
Risoluzione di freetz.wirsind.info... 87.98.242.177
Connessione a freetz.wirsind.info|87.98.242.177|:80... connesso.
HTTP richiesta inviata, in attesa di risposta... 404 Not Found
2013-05-29 20:29:12 ERRORE 404: Not Found.

Download failed - http://freetz.wirsind.info/FRITZ.Box_Fo ... 4.82.image -> error code 8

--2013-05-29 20:29:12-- http://freetz.magenbrot.net/FRITZ.Box_F ... 4.82.image
Risoluzione di freetz.magenbrot.net... 85.25.156.176
Connessione a freetz.magenbrot.net|85.25.156.176|:80... connesso.
HTTP richiesta inviata, in attesa di risposta... 403 Forbidden
2013-05-29 20:29:12 ERRORE 403: Forbidden.

Download failed - http://freetz.magenbrot.net/FRITZ.Box_F ... 4.82.image -> error code 8
ERROR: Could not download Firmwareimage.
make: *** [dl/fw/FRITZ.Box_Fon_WLAN_7170.AnnexB.en.29.04.82.image] Errore 3
gino@gino-laptop:~/freetz-1.1.3$ ^C
gino@gino-laptop:~/freetz-1.1.3$
Avatar utente
pystik
Advanced
Advanced
 
Messaggi: 252
Iscritto il: sab mag 02, 2009 3:49 pm
Ha ringraziato: 1 volta
Hai ringraziamenti: 0 volta

Messaggioda skizzo3000 » mer mag 29, 2013 6:53 pm

non è un probelma del tuo ubuntu ma della versione freetz che usi !
devi usare l'ultimo trunk così scarica l'ultimo fw disponibile senza problemi.

clonati questo
https://github.com/olistudent/freetz

cosi ti aggiorni con un solo comando !

Sk3
Avatar utente
skizzo3000
phpBB Moderator
phpBB Moderator
 
Messaggi: 4531
Iscritto il: sab lug 08, 2006 9:29 pm
Località: Padova
Ha ringraziato: 2 volte
Hai ringraziamenti: 63 volte

Messaggioda pystik » mer mag 29, 2013 7:27 pm

devo scaricare tutti quei file e metterli in un unica cartella (chiamata freetz immagino) cosi funziona tutto??7
ma c'è un modo per farli tutti insieme in unico download?

p.s.
li ho scaricati , in unico file, mo provo



________________

EDIT: mer mag 29, 2013 9:52 pm

anche questo non funge:
ho estratto la cartella nella home e quando lancio il make menudonfig mi restituisce questo:

gino@gino-laptop:~$ cd freetz-master
gino@gino-laptop:~/freetz-master$ make menuconfig
ERROR: The program git was not found in path.
Makefile:132: *** Some build prerequisites are missing! Please install the missing packages before trying again. Arresto.
Ultima modifica di mipaneb il gio mag 30, 2013 6:53 am, modificato 1 volta in totale.
Motivazione: unione post consecutivi
Avatar utente
pystik
Advanced
Advanced
 
Messaggi: 252
Iscritto il: sab mag 02, 2009 3:49 pm
Ha ringraziato: 1 volta
Hai ringraziamenti: 0 volta

Messaggioda skizzo3000 » mer mag 29, 2013 8:22 pm

The program git was not found in path ----> INSTALLA GIT !!
sudo apt-get install git


Sk3
Avatar utente
skizzo3000
phpBB Moderator
phpBB Moderator
 
Messaggi: 4531
Iscritto il: sab lug 08, 2006 9:29 pm
Località: Padova
Ha ringraziato: 2 volte
Hai ringraziamenti: 63 volte

Messaggioda pystik » mer mag 29, 2013 8:34 pm

grazie skizzo per il tuo impegno e per correggere le enormi cavolate che faccio ;
ma forse è il destino che non deve funzionare sta cosa..... io ce la sto metendo tutta sono 3 giorni che cerco di fare o almeno di caricare un firmware con openvpn ma non ci riesco ....
ecco cosa succede dopo che provo ad installare git:

gino@gino-laptop:~/freetz1.1.1$ make menuconfig
ERROR: The program git was not found in path.
Makefile:132: *** Some build prerequisites are missing! Please install the missing packages before trying again. Arresto.
gino@gino-laptop:~/freetz1.1.1$ sudo apt-get install git
[sudo] password for gino:
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze
Lettura informazioni sullo stato... Fatto
Il pacchetto git non ha versioni disponibili, ma è nominato da un altro
pacchetto. Questo può significare che il pacchetto è mancante, è obsoleto
oppure è disponibile solo all'interno di un'altra sorgente
E: Il pacchetto git non ha candidati da installare
gino@gino-laptop:~/freetz1.1.1$
Avatar utente
pystik
Advanced
Advanced
 
Messaggi: 252
Iscritto il: sab mag 02, 2009 3:49 pm
Ha ringraziato: 1 volta
Hai ringraziamenti: 0 volta

Messaggioda skizzo3000 » mer mag 29, 2013 9:16 pm

sai che alle volte il tasto TAB aiuta !!
se digiti
sudo apt-get install git<TAB><TAB>

ti esce l'elenco delle opzioni a completamento !

poi invece google ti risponde puntualmente ma devi fare la fatica di aprire il browser
https://www.google.it/#safe=off&output= ... nstall+git
che tra i primi 10 da questo
http://adammonsen.com/post/665

spero che ora tu riesca a compilare

Sk3

per questo messaggio l’autore skizzo3000 ha ricevuto un ringraziamento da:
pystik (mer mag 29, 2013 10:10 pm)
Valutazione: 33.33%
 
Avatar utente
skizzo3000
phpBB Moderator
phpBB Moderator
 
Messaggi: 4531
Iscritto il: sab lug 08, 2006 9:29 pm
Località: Padova
Ha ringraziato: 2 volte
Hai ringraziamenti: 63 volte

Messaggioda pystik » mer mag 29, 2013 9:45 pm

incredibile il make menuconfig è partito vediamo se mi fa pure il make : ho messo solo 2 pacchetto dropbear e openvpn.
grazie grazie ;D ;D ;D


p.s.
ihihiihhih grande skizzo!!!!!!!!!
funziona tuttttttoooooo;
mo vedo se riesco pure a caricarlo, poi ci vediamo su un altro tread per i problemi (che sono gia sicuro) con la vpn e android.



________________

EDIT: gio mag 30, 2013 2:36 pm

e te pareva che andava tutto liscio ???
in pratica ho montato tutto ma non aggancia la dsl
il modulo è leggermente diverso : 1.36.20.01 anziché 00; potrebbe essere quella la differenza??
cmq devo dire che ho importato un file di configurazione e dopo ho ricontrollato i parametri freetz
Ultima modifica di mipaneb il gio mag 30, 2013 1:28 pm, modificato 1 volta in totale.
Motivazione: unione messaggi consecutivi
Avatar utente
pystik
Advanced
Advanced
 
Messaggi: 252
Iscritto il: sab mag 02, 2009 3:49 pm
Ha ringraziato: 1 volta
Hai ringraziamenti: 0 volta

Prossimo

Torna a DS-Mod

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron