Pagina 1 di 1

MessaggioInviato: dom apr 26, 2009 8:18 am
da Tokka
Stavo provando a mettere la vers. 1.6, ma sia utilizzando la versione 1.6.0.9, che la 1.6.2 (da svn), in entrambi i casi mi ritrovo con questo errore :(

Assembler messages:
Error: unknown architecture `armv5tel'

Error: unrecognized option -march=armv5tel
src/add.c:1: error: bad value (armv5tel) for -march= switch
make[2]: *** [src/add.o] Error 1
make[1]: *** [gsm/lib/libgsm.a] Error 2
make: *** [codecs] Error 2

Sicuramente ha a che fare con la versione di hw, ma non ho ancora trovato come risolvere :'(
Se vi viene in mente qualcosa, fate un fischio ;D....io intanto continuo a cercare.
Dimenticavo :o : la distro è debian 5 :)
Tk


Edit: per la soluzione guardare questa discussione

MessaggioInviato: dom apr 26, 2009 10:00 am
da giacomo892
se scarichi i sorgenti da asterisk.org
apt-get install build-essential
./configure
make

non va?

MessaggioInviato: dom apr 26, 2009 10:14 am
da Tokka
Purtroppo no :(
Ho anche dato make menuselect, ho tolto qualcosa che non mi serve (tipo iax), ma sembra non volerne sapere. Oltretutto, ogni volta che compilo ci vogliono diverse ore Immagine

MessaggioInviato: dom apr 26, 2009 12:17 pm
da giacomo892
impossibile.. asterisk si compila in 3 minuti :) ma che piattaforma stai usando? prova comuque con

apt-get build-dep asterisk

e poi ricompila (in 5 minuti) :)

MessaggioInviato: dom apr 26, 2009 12:50 pm
da Tokka
giacomo892 ha scritto:impossibile.. asterisk si compila in 3 minuti :) ma che piattaforma stai usando? prova comuque con

apt-get build-dep asterisk

e poi ricompila (in 5 minuti) :)


Dunque...considerando la sezione....cosa potrebbe essere?Immagine
Battute a parte, come cpu è un arm a 266mhz, e come ram ne ha solo 32 mega....diciamo che non è proprio una scheggia Immagine

MessaggioInviato: dom apr 26, 2009 1:59 pm
da giacomo892
scusa.. ho trovato il post nei recent :) non ho visto la sezione . potresti cmq usare un pacchetto precompilato apt-get install asterisk.. tanto dalla 1.4 alla 1.6 non cambia quasi nulla..

MessaggioInviato: dom apr 26, 2009 2:05 pm
da Tokka
Eheh...anch'io al 101% non avrei guardato la sezione :P
Ero curioso di vedere come andava la 1.6, la 1.4 andava discretamente ;D

MessaggioInviato: dom apr 26, 2009 2:57 pm
da giacomo892
lol.. non cambia un cifra ... :)

MessaggioInviato: dom apr 26, 2009 3:02 pm
da giacomo892
cmq. sembra che non riconosca la tua architettura.. infatti anche su packeges.debian... (bho) ce un pacchetto di ast 1.6 ma è solo per i386

MessaggioInviato: dom apr 26, 2009 10:42 pm
da Tokka
In effetti sembra di sì....dando un chmod 777 qualcosa è cambiato (per scrupolo ho dato anche un make clean), ma per ora è servito a poco :(

MessaggioInviato: lun apr 27, 2009 11:11 pm
da user469
Se puo' servire

MessaggioInviato: lun apr 27, 2009 11:30 pm
da Tokka
Grazie per il link :)
Purtroppo l'avevo già visto :( (anche quello relativo a openwrt).
Ora sto ricompilando....ho visto che erano rimaste tracce della 1.4, magari gli davano fastidio ::) :D
Cmq dopo questo test, inizio a scendere con le versioni, magari ne trovo una che va ::)

MessaggioInviato: mar apr 28, 2009 8:20 pm
da lonegunman
perchè non fai il cross compilig invece di compilare nello slug ?

http://www.nslu2-linux.org/wiki/DebianS ... sCompiling

ho visto che alcune versioni di asterisk mancano dell'architetura armv5tel, non è che manchi anche nella versione che dici ?

MessaggioInviato: mer apr 29, 2009 12:08 pm
da Tokka
Non saprei  :-[ :-[
La 1.4 va come un orologio, apparte qualche problema di autenticazione...per cui ero curioso di provare la 1.6, ma a questo punto mi sa che resto sulla 1.4, la 1.6 la proverò direttamente sul fritz :D.
Grazie a tutti ;)