Miniguida riassuntiva JTAG <-> IP301

Modifiche Firmware e altro

Moderatore: phpBB Moderatori

Messaggioda Grunf2008 » ven gen 23, 2009 6:31 pm

@sebonweb

Ancora un altro errore... .)
Il comando tjtag viene cercato nei path di ricerca e non nella cartella corrente: prova con
Codice: Seleziona tutto
# sudo ./tjtag ...

Nota la differenza con il comando da te utilizzato
Codice: Seleziona tutto
# sudo tjtag ...


ciao e scusa per il tempo che hai perso :)
ciao
[/quote]


Grazie di tutto, stanotte riprovo e ti farò sapere.
Ciao.
Grunf
Grunf2008
Beginner
Beginner
 
Messaggi: 25
Iscritto il: ven ott 03, 2008 1:13 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda Grunf2008 » ven gen 23, 2009 7:42 pm

...Ho riprovato:  se digito "sudo ./tjtagv2" mi compare solo la scritta "../media/disk/tjtag/linus$" ; inoltre se digito la lunga stringa per il backup ("sudo ./tjtagv2 -backup:custom ....") compare ancora la scritta ".../media/disk/tjtag/linus$" ed il file CUSTOM.BIN ecc.. non viene scritto.
Acc...
Ciao.
Grunf2008
Grunf2008
Beginner
Beginner
 
Messaggi: 25
Iscritto il: ven ott 03, 2008 1:13 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda sebonweb » sab gen 24, 2009 9:10 am

Grunf2008 ha scritto:...Ho riprovato:  se digito "sudo ./tjtagv2" mi compare solo la scritta "../media/disk/tjtag/linus$" ; inoltre se digito la lunga stringa per il backup ("sudo ./tjtagv2 -backup:custom ....") compare ancora la scritta ".../media/disk/tjtag/linus$" ed il file CUSTOM.BIN ecc.. non viene scritto.
Acc...
Ciao.
Grunf2008



Sei sicuro di stare all'interno della cartella che contiene tjtagv2?

Dai un pwd per conosce in quale cartella attualmente ti trovi e
un ls -l per vedere che file ci sono nella cartella

ciao
sebonweb
Beginner
Beginner
 
Messaggi: 22
Iscritto il: mer nov 29, 2006 12:10 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda Grunf2008 » sab gen 24, 2009 10:10 am

sebonweb ha scritto:
Grunf2008 ha scritto:...Ho riprovato:  se digito "sudo ./tjtagv2" mi compare solo la scritta "../media/disk/tjtag/linus$" ; inoltre se digito la lunga stringa per il backup ("sudo ./tjtagv2 -backup:custom ....") compare ancora la scritta ".../media/disk/tjtag/linus$" ed il file CUSTOM.BIN ecc.. non viene scritto.
Acc...
Ciao.
Grunf2008




Sei sicuro di stare all'interno della cartella che contiene tjtagv2?

Dai un pwd per conosce in quale cartella attualmente ti trovi e
un ls -l per vedere che file ci sono nella cartella

ciao




La cartella è "  /media/disk/tjtag/linux  ": al comando   ls -l   il pc risponde così:

total 0
-rwx------ 1alex root 0 2009-01-23 00:57 tjtagv2


Se non fosse che i collegamenti di saldatura me li ha fatti un tecnico, sarei portato a ritenere che la mia jtag non funziona.
Ciao.
Grunf2008
Beginner
Beginner
 
Messaggi: 25
Iscritto il: ven ott 03, 2008 1:13 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda linuxmafia » sab gen 24, 2009 5:59 pm

Sto provando a flashare un telefono anche se non bloccato tramite jtag, ho costruito il cavo e collegato i fili al telefono ma non lo riconosce, ho provato con un tester ed è tutto ok.

Qualcuno può gentilmente chiarire i miei dubbi con la speranza che serva anche ad altri:

la numnerizione delle piazzole è  sopra 11  - 9  - 7 - 5 - 3 - 1
sotto                                                      12 - 10 - 8 - 6 - 4 - 2
1 è la quadrata.

Sulla parallela oltre ai cavetti indicati nella guida ne avete altri o restano tutte vuote ?

Le resistenze non hanno un verso e sono di 1/2w 100 Ohm

La porta parallela nel bios come è configurata ?
Nelle impostazioni del sistema operativo come è configurata ?
Qualcuno ha flashato con successo da un notebook ?

Grazie per le risposte.
linuxmafia
Advanced
Advanced
 
Messaggi: 114
Iscritto il: mer mag 21, 2008 8:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda cauntziro » sab gen 24, 2009 6:56 pm

che S.O. stai usando?
cosa intendi per 'non lo riconosce', che messaggi da il programma tjtag?
cauntziro
Beginner
Beginner
 
Messaggi: 56
Iscritto il: mer dic 10, 2008 11:36 am
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda linuxmafia » sab gen 24, 2009 9:23 pm

Uso windows xp, l'errore che mi restituisce è "unknown or no cpu cjip id detected"
linuxmafia
Advanced
Advanced
 
Messaggi: 114
Iscritto il: mer mag 21, 2008 8:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda cauntziro » sab gen 24, 2009 10:25 pm

leggendo la discussione ho visto che hanno creato una nuova versione del tjtag, prova la vecchia se hai usato la nuova.
potrebbe anche essere il cavo jtag troppo lungo. la versione unbuffered che hai è sensibile ai disturbi, quello che ho realizzato io misurerà si e no una decina di centimetri dalle piazzole alla porta parallela
cauntziro
Beginner
Beginner
 
Messaggi: 56
Iscritto il: mer dic 10, 2008 11:36 am
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda linuxmafia » sab gen 24, 2009 10:49 pm

Grazie per l'interesse mostrato, in effetti da 3 minuti sta funzionando sta al 2%, il problema erano i cavi lunghi.

Comunque io ho settato la parallela dal bios in bidirezionale, le piazzole giuste sono quelle che ho descritto prima e le resistenze non hanno un verso, il telefono logicamente va alimentato e si può flashare anche senza rimontare la parte superiore quindi solo con la scheda e l'alimentazione.

Sembrano cose banali ma ti assicuro che almeno io a utonto che ci ha provato per la prima volta mi sono fatto queste domande.
linuxmafia
Advanced
Advanced
 
Messaggi: 114
Iscritto il: mer mag 21, 2008 8:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda sebonweb » dom gen 25, 2009 8:40 am

@Grunf2008:

Se tutte le operazioni precedenti sono ok, dando il comando sudo ./tjtagv2 -backup:cfe
un oputput di risposta deve venire visualizzato, nel caso specifico; se tjtag non riesce a leggere la flash ti deve apparire qualcosa del genere:
Codice: Seleziona tutto
==========================================
 EJTAG Debrick Utility v2.1.4-Tornado-MOD
==========================================

Probing bus ... Done

Instruction Length set to 5

CPU Chip ID: 11111111111111111111111111111111 (FFFFFFFF)
*** Unknown or NO CPU Chip ID Detected ***

*** Possible Causes:
    1) Device is not Connected.
    2) Device is not Powered On.
    3) Improper JTAG Cable.
    4) Unrecognized CPU Chip ID.


Cause:
ip301 non alimentato
cavo troppo lungo
collegamenti errati
saldature fredde e/o in corto

Armati di pazienza e ricontrolla il tutto a cominciare dal cavo.

ciao

p.s. per comodita' se linux non ti e' troppo familiare, puoi utilizzare tjttag in versione windows, dai un'occhiata al messsagio iniziale che aggiorno sempre...
sebonweb
Beginner
Beginner
 
Messaggi: 22
Iscritto il: mer nov 29, 2006 12:10 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda Grunf2008 » dom gen 25, 2009 10:08 am

sebonweb ha scritto:@Grunf2008:

Se tutte le operazioni precedenti sono ok, dando il comando sudo ./tjtagv2 -backup:cfe
un oputput di risposta deve venire visualizzato, nel caso specifico; se tjtag non riesce a leggere la flash ti deve apparire qualcosa del genere:
Codice: Seleziona tutto
==========================================
 EJTAG Debrick Utility v2.1.4-Tornado-MOD
==========================================

Probing bus ... Done

Instruction Length set to 5

CPU Chip ID: 11111111111111111111111111111111 (FFFFFFFF)
*** Unknown or NO CPU Chip ID Detected ***

*** Possible Causes:
    1) Device is not Connected.
    2) Device is not Powered On.
    3) Improper JTAG Cable.
    4) Unrecognized CPU Chip ID.


Cause:
ip301 non alimentato
cavo troppo lungo
collegamenti errati
saldature fredde e/o in corto

Armati di pazienza e ricontrolla il tutto a cominciare dal cavo.

ciao

p.s. per comodita' se linux non ti e' troppo familiare, puoi utilizzare tjttag in versione windows, dai un'occhiata al messsagio iniziale che aggiorno sempre...



@sebonweb

Niente da fare, la risposta è sempre .../media/disk/tjtag/linux$    e basta ..

Esaminando con la lente la piazzola della jtag sul telefono ho notato che è ormai disastrata ...  salda e risalda ....
Non vorrei che ci fosse veramente un corto circuito tra i cavi....: domani torno dal radiotecnico e proverò a far saldare i cavi direttamente sulle piste, escludendo la piazzola.
La mia jtag ha i cavi di 14 cm.
Grazie per tutto l'interessamento.  Ciao.
Grunf2008
Beginner
Beginner
 
Messaggi: 25
Iscritto il: ven ott 03, 2008 1:13 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda linuxmafia » dom gen 25, 2009 10:25 am

@Grunf2008

Nella cartella dove hai tjtag prova a dare questi comandi:

sudo bash
ti chiederà la password inseriscila, il prompt cambia da $ a # adesso hai i permessi di root, dai il comando : chmod 777 tjtagv2, fai un ls -al e posta il risultato.

In alternativa mappa la porta 22 del router verso l'ip del tuo linux e contattami che te lo risolvo io da remoto.
linuxmafia
Advanced
Advanced
 
Messaggi: 114
Iscritto il: mer mag 21, 2008 8:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda Grunf2008 » dom gen 25, 2009 11:08 am

linuxmafia ha scritto:@Grunf2008

Nella cartella dove hai tjtag prova a dare questi comandi:

sudo bash
ti chiederà la password inseriscila, il prompt cambia da $ a # adesso hai i permessi di root, dai il comando : chmod 777 tjtagv2, fai un ls -al e posta il risultato.

In alternativa mappa la porta 22 del router verso l'ip del tuo linux e contattami che te lo risolvo io da remoto.


@ linuxmafia

Ho fatto come hai detto ed al comando  ls -al ottengo questa risposta:

total 32
drwx------ 2 alex root 16384 2008-12-31  13:11  .
drwx------ 5 alex root 16384 2009-01-22  12:07  .  .
-rwx ------ 1 alex root          0 2009-01-23  00:57  tjtagv2  
root@ubuntu:/media/disk/tjtag/linux#

Il portatile che utilizzo con linux è collegato al telefono tramite la jtag, ma non al router: quindi non posso andare su internet.
Al router è collegato un altro pc (fisso) che ha xp e che utilizzo per scrivere sul forum.
Ciao e grazie per l'interessamento.
Grunf2008
Beginner
Beginner
 
Messaggi: 25
Iscritto il: ven ott 03, 2008 1:13 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda linuxmafia » dom gen 25, 2009 11:10 am

Ok quindi adesso hai provato ad eseguire il software con il comando ./tjtagv2    ?
Che risultato ti da ?
linuxmafia
Advanced
Advanced
 
Messaggi: 114
Iscritto il: mer mag 21, 2008 8:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda crisman » dom gen 25, 2009 11:26 am

Grunf2008 ha scritto:

-rwx ------ 1 alex root          0 2009-01-23  00:57  tjtagv2  
root@ubuntu:/media/disk/tjtag/linux#


E' normale che non ti funzioni!!! Il file tjtagv2 è vuoto; ha dimensione 0.
Hai sbagliato qualcosa nei passaggi precedenti. Ricontrolla il tutto...
crisman
Beginner
Beginner
 
Messaggi: 43
Iscritto il: lun nov 10, 2008 1:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

PrecedenteProssimo

Torna a Firmware

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite