[risolto] 1020 mezzo morto

Fritz!Box Fon ATA 1020

Moderatore: phpBB Moderatori

Messaggioda drex » sab ott 23, 2010 12:19 pm

Salve  a tutti,

è il mio primo post non mi sono presentato ma vi seguo da 3 anni :)

ho un 1020 che si riavvia di continuo, risponde solo in ftp al 192.168.178.2

vi spiego meglio, aggiornato a firm 11.04.01 originale, poi sul sul sito di skizzo3000 (scusate mod se faccio spam) ho deciso di installare il firm beta FRITZ.Box_Fon_ata.en.11.04.28-5306 ma dava dei problemi (si piantava tutto e dovevo riavviarlo), quindi ho provato a fare un recovery col 11.04.01 cambiando anche la variabile a quel firm. ma non ci sono riuscito ne con la versione en,si blocca sul recovery mtd1, mentre la versione tedesca si blocca sul mtd0.

ho provato anche un recovery via ftp ma quando carica il file filesystem.image mi butta fuori.

voi che siete moooolto piu esperti di me mi potete aiutare??

Grazie in anticipo.
Ultima modifica di drex il dom ott 24, 2010 1:14 pm, modificato 1 volta in totale.
drex
PrimoLivello
PrimoLivello
 
Messaggi: 6
Iscritto il: sab ott 23, 2010 12:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda linus » sab ott 23, 2010 12:32 pm

Solitamente il riavvio continuo è causato dalla non corrispondenza delle variabili impostate con il firmware caricato. Controlla se le variabili ambiente sono corrette via ftp.

linus
Solo se sai cercare riuscirai nel tuo intento, la ricerca ci accompagna per tutta la vita e fa si che cresciamo ogni giorno un po'. Se hai la minestra pronta e riscaldata, non riuscirai mai a gustare il suo vero sapore e trovarne il piacere.
Avatar utente
linus
Guru
Guru
 
Messaggi: 4105
Iscritto il: lun ago 14, 2006 10:27 am
Ha ringraziato: 2 volte
Hai ringraziamenti: 25 volte

Messaggioda mipaneb » sab ott 23, 2010 12:55 pm

Ciao e benvenuto sul forum

Ho l'impressione che il fw che avevi a bordo sia stato creato sulla base della versione tedesca (Skizzo potrebbe confermare o smentire), ed in tal caso bisogna vedere se il bootloader è stato cambiato, e/o altre variabili essenziali

Vedi anche:
http://www.vocesuip.com/cerco_aggiornam ... 822.0.html
http://www.vocesuip.com/recovery_fbf_at ... 427.0.html

Comunque, se lo scopo è inserire il fw annex A originale AVM, sarebbe meglio seguire il consiglio di Linus, se vuoi pubblica le attuali variabili (da ftp, quote GETENV xxxx, vedi wiki)






Stay tuned
Michele






_______________________
Fritz!Box 7170v1 58.04.82 - TeleTu7M - 7072/480 - s/n 13/19 - LA 25/21
Fonera - Speedport W701V - Fritz!Fon 7150 - SPA2102 - Zyxel 660HW61
Avatar utente
mipaneb
phpBB Moderator
phpBB Moderator
 
Messaggi: 4173
Iscritto il: mar ott 16, 2007 2:10 pm
Località: Monte Nieddu - Sardegna
Ha ringraziato: 22 volte
Hai ringraziamenti: 75 volte

Messaggioda drex » sab ott 23, 2010 1:03 pm

Ciao grazie per la risposta veloce!!

queste sono le mie variabili impostate




ftp> quote GETENV HWRevision
HWRevision            71

200 GETENV command successful
ftp> quote GETENV ProductID
ProductID            Fritz_Box_FON_ATA

200 GETENV command successful
ftp> quote GETENV SerialNumber
SerialNumber          0000000000000000

200 GETENV command successful
ftp> quote GETENV annex
annex                B

200 GETENV command successful
ftp> quote GETENV autoload
autoload              yes

200 GETENV command successful
ftp> quote GETENV bootloaderVersion
bootloaderVersion    0.18.01

200 GETENV command successful
ftp> quote GETENV bootserport
bootserport          tty0

200 GETENV command successful
ftp> quote GETENV bluetooth
bluetooth            00:04:0E:FF:FF:07

200 GETENV command successful
ftp> quote GETENV cpufrequency
cpufrequency          150000000

200 GETENV command successful
ftp> quote GETENV firstfreeaddress
firstfreeaddress      0x94730258

200 GETENV command successful
ftp> quote GETENV firmware_version
firmware_version      avme

200 GETENV command successful
ftp> quote GETENV firmware_info
firmware_info        11.04.01

200 GETENV command successful
ftp> quote GETENV flashsize
flashsize            0x00400000

200 GETENV command successful
ftp> quote GETENV maca
maca                  00:1A:4F:7C:6E:26

200 GETENV command successful
ftp> quote GETENV macb
macb                  00:1A:4F:7C:6E:27

200 GETENV command successful
ftp> quote GETENV macwlan
macwlan              00:1A:4F:9A:EA:D8

200 GETENV command successful
ftp> quote GETENV macdsl
macdsl                00:1A:4F:7C:6E:28

200 GETENV command successful
ftp> quote GETENV memsize
memsize              0x01000000

200 GETENV command successful
ftp> quote GETENV modetty0
modetty0              38400,n,8,1,hw

200 GETENV command successful
ftp> quote GETENV modetty1
modetty1              38400,n,8,1,hw

200 GETENV command successful
ftp> quote GETENV mtd0
mtd0                  0x900C0000,0x903C0000

200 GETENV command successful
ftp> quote GETENV mtd1
mtd1                  0x90010000,0x900C0000

200 GETENV command successful
ftp> quote GETENV mtd2
mtd2                  0x90000000,0x90010000

200 GETENV command successful
ftp> quote GETENV mtd3
mtd3                  0x903C0000,0x903E0000

200 GETENV command successful
ftp> quote GETENV mtd4
mtd4                  0x903E0000,0x90400000

200 GETENV command successful
ftp> quote GETENV my_ipaddress
my_ipaddress          192.168.178.2

200 GETENV command successful
ftp> quote GETENV prompt
prompt                AVM_Ar7

200 GETENV command successful
ftp> quote GETENV reserved
reserved              00:04:0E:FF:FF:00

200 GETENV command successful
ftp> quote GETENV req_fullrate_freq
req_fullrate_freq    125000000

200 GETENV command successful
ftp> quote GETENV sysfrequency
sysfrequency          125000000

200 GETENV command successful
ftp> quote GETENV urlader-version
urlader-version      98

200 GETENV command successful
ftp> quote GETENV usb_board_mac
usb_board_mac        00:1A:4F:7C:6E:29

200 GETENV command successful
ftp> quote GETENV usb_rndis_mac
usb_rndis_mac        00:1A:4F:7C:6E:2A

200 GETENV command successful
ftp> quote GETENV usb_device_id
usb_device_id        0x4701

200 GETENV command successful
ftp> quote GETENV usb_revision_id
usb_revision_id      0x0100

200 GETENV command successful
ftp> quote GETENV usb_device_name
usb_device_name      USB DSL Device

200 GETENV command successful
ftp> quote GETENV usb_manufacturer_name
usb_manufacturer_name  AVM

200 GETENV command successful
ftp> quote GETENV wlan_key
501 wlan_key environment variable not set.
ftp> quote GETENV kernel_args
501 kernel_args environment variable not set.
ftp>

mi date una mano? grazie :)
Ultima modifica di mipaneb il mer ago 17, 2011 6:11 am, modificato 1 volta in totale.
Motivazione: rimozione quote integrale
drex
PrimoLivello
PrimoLivello
 
Messaggi: 6
Iscritto il: sab ott 23, 2010 12:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda linus » sab ott 23, 2010 3:12 pm

Innanzi tutto prova a cambiare l'annex da ftp in A e riavviare il fritz!box.

Per il resto le variabili sembrano corrette, se non ti va ancora il recovery da windows, prova a seguire questa vecchia procedura.

http://www.vocesuip.com/come_fare_il_re ... 14.45.html


linus
Solo se sai cercare riuscirai nel tuo intento, la ricerca ci accompagna per tutta la vita e fa si che cresciamo ogni giorno un po'. Se hai la minestra pronta e riscaldata, non riuscirai mai a gustare il suo vero sapore e trovarne il piacere.
Avatar utente
linus
Guru
Guru
 
Messaggi: 4105
Iscritto il: lun ago 14, 2006 10:27 am
Ha ringraziato: 2 volte
Hai ringraziamenti: 25 volte

Messaggioda drex » sab ott 23, 2010 3:43 pm

Ciao linus

ho modificato il annex A

provata procedura con recover.exe ma mi restituisce sempre questo errore

C:\fritzbox>recover.exe -f update.image
recover.exe: error = 9

questo è il log del recovery tedesco

FRITZ!Box Fon ata suchen an: 192.168.178.2
Eine Anlage gefunden! - Ermitteln der aktuellen Version.
Version erfolgreich ermittelt!
    Hardware: FRITZ!Box Fon ata
    Urlader: 98
    Firmware: 11.04.01
Flashbereich (mtd1)
    Lösche Flashbereich (mtd1)
    Restauriere Flashbereich (mtd1)
    Überprüfe Flashbereich (mtd1)
    Erfolgreich
Flashbereich (mtd0)
    Lösche Flashbereich (mtd0)
Recover der Partition mtd0 fehlgeschlagen! WinError 10060

questo il log della versione inglese

Searching FRITZ!Box Fon ata at: 192.168.178.2
One system found! - Detecting the current version.
Version successfully detected!
    Hardware: FRITZ!Box Fon ata
    Bootstrap: 98
    Firmware: 11.04.01
Flash area (mtd1)
    Deleting flash area (mtd1)
    Restoring flash area (mtd1)
    Checking flash area (mtd1)
    Successful
Flash area (mtd0)
    Deleting flash area (mtd0)
Could not recover the partition mtd0! WinError 10060

questo è il log del recovery via FTP:

C:\fritzbox>ftp 192.168.178.2
Connesso a 192.168.178.2.
220 ADAM2 FTP Server ready.
Utente (192.168.178.2:(none)): adam2
331 Password required for adam2.
Password:
230 User adam2 successfully logged in.
ftp>
ftp>
ftp>
ftp> debug
Debug di On in corso...
ftp> bin
---> TYPE I
200 Type set to I.
ftp> quote MEDIA FSLH
---> MEDIA FSLH
200 Media set to FSLH.
ftp> put kernel.image "kernel.image mtd1"
---> PORT 192,168,178,30,238,142
200 Port command successful.
---> STOR kernel.image mtd1
150 Opening BINARY mode data connection for file transfer.
226 Transfer complete.
ftp: 700680 bytes sent in 0,79secondi 883,58Kbyte/sec)
ftp> put filesystem.image "filesystem.image mtd0"
---> PORT 192,168,178,30,238,143
Connessione chiusa dall'host remoto.

qualche idea?
Ultima modifica di mipaneb il mer ago 17, 2011 6:12 am, modificato 1 volta in totale.
Motivazione: rimozione quote integrale
drex
PrimoLivello
PrimoLivello
 
Messaggi: 6
Iscritto il: sab ott 23, 2010 12:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda mipaneb » sab ott 23, 2010 3:58 pm

Per evitare intoppi sul recovery, cura scrupolosamente di trovarti in tutte le condizioni suggerite qui:
http://wiki.vocesuip.com/index.php?titl ... age_di_AVM

Poi, potresti provare così: imposta solo queste variabili da ftp (attenzione alla sintassi):

Codice: Seleziona tutto

quote SETENV annex,A
quote SETENV firmware_version,avme



... e senza spegnere il Fritz (a differenza di quanto richiesto normalmente), lancia il recovery inglese annex A:
ftp://ftp.avm.de/fritz.box/fritzbox.fon ... -image.exe


Se non dovesse andare, rimetti annex,B e firmware_version,avm e prova la stessa tecnica col recovery tedesco:
ftp://ftp.avm.de/fritz.box/fritzbox.fon ... -image.exe

In qualche modo, l'interfaccia web la devi recuperare, concordo con linus che le restanti variabili sono a posto, l'unico dubbio è sul bootloader: bootloaderVersion 0.18.01 - non saprei se è quello originale





Stay tuned
Michele






_______________________
Fritz!Box 7170v1 58.04.82 - TeleTu7M - 7072/480 - s/n 13/19 - LA 25/21
Fonera - Speedport W701V - Fritz!Fon 7150 - SPA2102 - Zyxel 660HW61
Avatar utente
mipaneb
phpBB Moderator
phpBB Moderator
 
Messaggi: 4173
Iscritto il: mar ott 16, 2007 2:10 pm
Località: Monte Nieddu - Sardegna
Ha ringraziato: 22 volte
Hai ringraziamenti: 75 volte

Messaggioda drex » sab ott 23, 2010 4:14 pm

mi sta venendo un dubbio... uso windows 7 sarà quello il problema??

poi è come se non riuscisse ad accedere alla mtd0....
Ultima modifica di drex il sab ott 23, 2010 4:19 pm, modificato 1 volta in totale.
drex
PrimoLivello
PrimoLivello
 
Messaggi: 6
Iscritto il: sab ott 23, 2010 12:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda firstlevel » sab ott 23, 2010 4:23 pm

la versione di firmware che hai caricato ha una diversa formattazione degli mtd, l'unico modo per tornare indietro e caricare il vecchio mtd2 e poi fare il recovery
se cerchi nel forum troverai varie indicazioni su come ripristinare un mtd2
firstlevel
Expert
Expert
 
Messaggi: 737
Iscritto il: mar giu 29, 2010 12:22 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 39 volte

Messaggioda linus » sab ott 23, 2010 4:27 pm

Il bootloader dovrebbe essere quello, viste le tue ultime info, credo che parte del problema sia proprio l'uso di windows 7 che crea qualche problema poiché non vi è alcun recovery scritto per questo sistema operativo, e XP risulta emulato così anche il dos.

Vedi se hai la possibilità di trovare un computer con windows xp nativo.

Cito al tal proposito:

mipaneb ha scritto:[CUT]
visto il messaggio WinError 10060, mi accerterei di utilizzare un PC da tavolo con winxp, con le consuete impostazioni di rete, ed escludendo eventuali virtualizzatori, antivirus e firewall, che possono generare quel tipo di errore

Stay tuned
Michele


linus
Solo se sai cercare riuscirai nel tuo intento, la ricerca ci accompagna per tutta la vita e fa si che cresciamo ogni giorno un po'. Se hai la minestra pronta e riscaldata, non riuscirai mai a gustare il suo vero sapore e trovarne il piacere.
Avatar utente
linus
Guru
Guru
 
Messaggi: 4105
Iscritto il: lun ago 14, 2006 10:27 am
Ha ringraziato: 2 volte
Hai ringraziamenti: 25 volte

Messaggioda drex » sab ott 23, 2010 4:28 pm

firstlevel ha scritto:la versione di firmware che hai caricato ha una diversa formattazione degli mtd, l'unico modo per tornare indietro e caricare il vecchio mtd2 e poi fare il recovery
se cerchi nel forum troverai varie indicazioni su come ripristinare un mtd2




grazie provo anche questa!!!

dopo posto i risultati cosi può essere utile x la comunità :)
drex
PrimoLivello
PrimoLivello
 
Messaggi: 6
Iscritto il: sab ott 23, 2010 12:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda linus » sab ott 23, 2010 4:39 pm

ti consiglio prima di trovare un pc adatto allo scopo, e mi ripeto invitandoti al leggere questo post:

http://www.vocesuip.com/ennesimo_proble ... quickreply

la lunghezza degli mtd corrisponde sia per posizione che per lunghezza con quella del dispositivo originario secondo gli indirizzi riportati da te.

linus
Solo se sai cercare riuscirai nel tuo intento, la ricerca ci accompagna per tutta la vita e fa si che cresciamo ogni giorno un po'. Se hai la minestra pronta e riscaldata, non riuscirai mai a gustare il suo vero sapore e trovarne il piacere.
Avatar utente
linus
Guru
Guru
 
Messaggi: 4105
Iscritto il: lun ago 14, 2006 10:27 am
Ha ringraziato: 2 volte
Hai ringraziamenti: 25 volte

Messaggioda drex » sab ott 23, 2010 9:47 pm

dove posso trovare il file mtd2.bin per il fon ata 1020?? :)

_________


EDIT:
Ragazzi ho risolto!

il problema era windows 7 che non è compatibile con il recovery.

Rifatta tutta la procedura su XP e tutto è andato a buon fine.

Grazie ancora per il supporto.

Saluti.

Potete chiudere. :)
Ultima modifica di mipaneb il mer ago 17, 2011 6:14 am, modificato 1 volta in totale.
Motivazione: unione messaggi consecutivi
drex
PrimoLivello
PrimoLivello
 
Messaggi: 6
Iscritto il: sab ott 23, 2010 12:06 pm
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda Tokka » dom ott 24, 2010 11:48 am

drex ha scritto:
Potete chiudere. :)

Non trattandosi di un'assistenza, ti invito a modificare il titolo del primo post ed aggiungere [Risolto], grazie.
Fritz
vari...
Ip-301 lock & free
Nslu2 -> debian [lenny]
Gigaset S450IP
Sto rimettendo in piedi la baracca
Avatar utente
Tokka
Guru
Guru
 
Messaggi: 4151
Iscritto il: gio feb 23, 2006 11:04 am
Località: 7113 fw mod con asterisk 1.8, 7240 fw mod con asterisk 11, 7140 fw mod con umts
Ha ringraziato: 9 volte
Hai ringraziamenti: 12 volte


  • Argomento simile
    Risposte
    Visite
    Autore

Torna a FBF ATA

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite