richiesta firmware fb fon wl 08.04.49 eng annex b con telnet attivabile -RISOLTO

Fritz!Box Fon WLAN

Moderatore: phpBB Moderatori

Messaggioda cpthrlk » mer nov 04, 2009 10:25 pm

Un saluto agli amici del forum, purtroppo dopo un aggiornamento del mio fritz box fon wlan all'ultima versione disponibile di firmware non riesco più a tornare indietro.
Io sono partito dalla versione 08.04.01 inglese annex b ed ora mi ritrovo con la 08.04.49 annex b inglese senza telnet. I file in circolazione con telnet sono tutti basati sulla versione annex a e quindi io non ho modo di installarli perchè il fritz mi dice versione errata quando tento di farglieli digerire tramite interfaccia web.
Aggiungo che riesco a collegarmi senza problemi tramite ftp ed ho tentato anche di cambiare i parametri sotto elencati:
quote SETENV annex A
quote SETENV HWRevision 66
quote SETENV ProductID Fritz_Box_WLAN
quote SETENV firmware_version avme
quote SETENV firmware_info 08.04.01
ma spegnendo il router questi ricambiano da soli.
Mi sono letto pagine e pagine di forum prima di ricorrere al vostro aiuto.
Vi ringrazio anticipatamente.
Ultima modifica di cpthrlk il gio nov 05, 2009 5:44 pm, modificato 1 volta in totale.
cpthrlk
PrimoLivello
PrimoLivello
 
Messaggi: 10
Iscritto il: gio mag 11, 2006 10:39 am
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda mipaneb » gio nov 05, 2009 7:41 am

Hai seguito questa procedura?
http://wiki.vocesuip.com/index.php?titl ... _e_sup.%29

Se non effettui il cambio del bootloader, le modifiche non verranno conservate; potresti comunque provare a lanciare il recovery senza spegnere il Fritz

EDIT: forse può aiutare anche la lettura di questo thread, dal post #28 in poi:
http://www.vocesuip.com/repeter_con_una ... msg6614184




Stay tuned
Michele






_______________________
Fritz!Box Wlan 7170v1 - fw 58.04.76 - Tele2 2Mega - 2464/352 - s/n 31/26 - LA 26/21
Fonera - Speedport W701V - Zyxel 660HW61
Ultima modifica di mipaneb il gio nov 05, 2009 9:04 am, modificato 1 volta in totale.
Avatar utente
mipaneb
phpBB Moderator
phpBB Moderator
 
Messaggi: 4174
Iscritto il: mar ott 16, 2007 2:10 pm
Località: Monte Nieddu - Sardegna
Ha ringraziato: 22 volte
Hai ringraziamenti: 75 volte

Messaggioda cpthrlk » gio nov 05, 2009 9:27 am

Il problema è appunto telnet.
Io nella versione firmware attuale non ho possibilità di attivarlo perchè non presente.
Ho provato a fare il recover senza spegnere, funziona, ora ho la versione annex a  08.04.49 però non mi accetta nessun firmware di quelli disponibili con il telnet attivabile per poter effettuare il cambio bootloader e downgrade. Necessito di un firmware nativo annex b con possibilità di attivare il telnet e seguire la procedura.
Grazie
cpthrlk
PrimoLivello
PrimoLivello
 
Messaggi: 10
Iscritto il: gio mag 11, 2006 10:39 am
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda mipaneb » gio nov 05, 2009 10:12 am

cpthrlk ha scritto:CUT
Necessito di un firmware nativo annex b con possibilità di attivare il telnet e seguire la procedura.






Qualcuno si è trovato bene seguendo questa procedura (i naviganti dicono "a barca persa"):

1) esaminare il codice stampato sull'etichetta 2000-xxxx sul fondo del router

2) scaricare il file eseguibile corrispondente a xxxx su questa directory: ftp://service.avm.de

3) lanciare la procedura di ripristino guidata ufficiale AVM, che riporta il router alle condizioni di fabbrica (col firmware tedesco annex B preistorico)

4) fare l'upgrade alla versione inglese annex A desiderata, come da Wiki






Stay tuned
Michele






_______________________
Fritz!Box Wlan 7170v1 - fw 58.04.76 - Tele2 2Mega - 2464/352 - s/n 31/26 - LA 26/21
Fonera - Speedport W701V - Zyxel 660HW61
Avatar utente
mipaneb
phpBB Moderator
phpBB Moderator
 
Messaggi: 4174
Iscritto il: mar ott 16, 2007 2:10 pm
Località: Monte Nieddu - Sardegna
Ha ringraziato: 22 volte
Hai ringraziamenti: 75 volte

Messaggioda cpthrlk » gio nov 05, 2009 2:48 pm

Grazie al firmware mandatomi da lonegunman ho cambiato il fritz da annex b in annex a e dovrebbe anche aver sostituito il boot loader con quello vecchio con possibilità di attivare telnet, poi da ftp do questi comandi:

quote SETENV annex A
quote SETENV HWRevision 66
quote SETENV ProductID Fritz_Box_WLAN
quote SETENV firmware_version avme
quote SETENV firmware_info 08.04.01
quit

faccio il recover con la versione 08.04.26 annex a inglese ed ottengo questo errore:

Searching FRITZ!Box Fon WLAN (Annex A) at: 192.168.178.1
One system found! - Detecting the current version.
Version successfully detected!
    Hardware: FRITZ!Box Fon WLAN (Annex A)
    Bootstrap: 1309
    Firmware: 08.04.01
Flash area (mtd1)
    Deleting flash area (mtd1)
    Restoring flash area (mtd1)
    Checking flash area (mtd1)
Could not check the partition mtd1! WinError -4

A questo punto posso solo fare recover con la 08.04.49 inglese annex a e sono punto e a capo cioè da annex b iniziale ora almeno è annex a.
Mi sorge il dubbio che io debba risostituire il boot loader anche se il firmware lo dovrebbe aver fatto da solo.
Ultima modifica di cpthrlk il gio nov 05, 2009 2:51 pm, modificato 1 volta in totale.
cpthrlk
PrimoLivello
PrimoLivello
 
Messaggi: 10
Iscritto il: gio mag 11, 2006 10:39 am
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda lonegunman » gio nov 05, 2009 3:37 pm

non ha sostituito il bootloader con quello vecchio ma con quello nuovo settato annex A ...

non ho urlader adam2 per poter sostituire EVA (quello nuovo) con ADAM (quello vecchio)

come ti dicevo nella mail quel firmware è altamente sperimentale ... comunque dovresi avere il telnet per poter fare il downgrade del bootloader
Software is like sex, it's better when it's free (Linus Torvalds)
Avatar utente
lonegunman
Guru
Guru
 
Messaggi: 1569
Iscritto il: gio gen 18, 2007 11:38 am
Località: Milano
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda cpthrlk » gio nov 05, 2009 3:49 pm

Nessun problema ora provo e appena riesco farò sapere.
Confermo telnet perfettamente funzionante  ;)
cpthrlk
PrimoLivello
PrimoLivello
 
Messaggi: 10
Iscritto il: gio mag 11, 2006 10:39 am
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta

Messaggioda cpthrlk » gio nov 05, 2009 5:43 pm

Operazione chirurgica riuscita perfettamente o quasi devo sistemare bene le variabili:
accetta firmware annex a ma scrive su interfaccia web annex b
Ora sono tornato alla 08.04.01 eng
Vi ringrazio tutti per l'aiuto e soprattutto lonegunman per il firmware senza il quale non avrei potuto fare il downgrade.
cpthrlk
PrimoLivello
PrimoLivello
 
Messaggi: 10
Iscritto il: gio mag 11, 2006 10:39 am
Ha ringraziato: 0 volta
Hai ringraziamenti: 0 volta


  • Argomento simile
    Risposte
    Visite
    Autore

Torna a FBF WLAN

Chi c’è in linea

Visitano il forum: Nessuno e 1 ospite

cron