[risolto] 6840 LTE perdita interfaccia accesso

Discussioni riguardante il Firmware

Moderatore: phpBB Moderatori

Messaggioda reaudace » sab mar 11, 2017 9:40 am

Salve,
ho acquistato un FritzBox tedesco anno di costruzione 2013, rilevato dal codice numero di serie C394....
Ho eseguito la procedura di accesso FTP e inserito il comando "quote SETENV firmware_version avme". Il comando ha avuto successo, chiusura della sessione con quit.
Al riavvio successivo il LED Power lampeggia, la scheda di rete presenta "Cavo rete scollegato" e impossibilità di accedere all'interfaccio del FritzBox.
Seguono tentativi di riconnessione ma senza successo.
L'unico accesso possibile è via FTP.
Come posso procedere all'aggiornamento internazionale e il ripristino del FB?
Prima della sessione FTP l'OS era aggiornato al 6.50 tedesco.
reaudace
PrimoLivello
PrimoLivello
 
Messaggi: 5
Iscritto il: sab ago 02, 2014 10:21 pm
Ha ringraziato: 4 volte
Hai ringraziamenti: 0 volta

Messaggioda mipaneb » sab mar 11, 2017 8:51 pm

.
.
.

Ciao e benvenuto sul forum

Saltando alcuni passaggi sui quali appari non digiuno in materia, arrivo al sodo: se volevi cambiare la versione del firmware con quella nazionalizzata non tedesca, come mai non hai fatto il recovery internazionale subito dopo il cambio della variabile?
ftp://ftp.avm.de/fritz.box/fritzbox_684 ... -image.exe




Stay tuned
Michele




_______________________
Fritz!Box 7170v1 58.04.84 - Alice7M - ITU 992.1 - 8125/478 - s/n 18/20 - LA 25/23
Fonera - Speedport W701V - Fritz!Fon 7150 - SPA2102 - Zyxel 660HW61

per questo messaggio l’autore mipaneb ha ricevuto un ringraziamento da:
reaudace (sab apr 08, 2017 5:29 pm)
Valutazione: 33.33%
 
Avatar utente
mipaneb
phpBB Moderator
phpBB Moderator
 
Messaggi: 4166
Iscritto il: mar ott 16, 2007 2:10 pm
Località: Monte Nieddu - Sardegna
Ha ringraziato: 22 volte
Hai ringraziamenti: 75 volte

Messaggioda reaudace » sab apr 08, 2017 5:25 pm

Grazie per la tua risposta.
In effetti, sulle WIKI ci sono indicazioni sulla strategia da utilizzare e alla fine ne ho ricavata una che mi ha portato a concludere positivamente il cambio sul primo 6840 LTE del 2013 che sta funzionando bene.
Scusami se ti rispondo in forte ritardo.

Se ti è possibile puoi collaborare per risolvere un altro caso?
Il caso riguarda un FB 6840 LTE anno di costruzione 2015 essendo il seriale F...
Premessa: inserendo la SIM della TRE funziona e si collega in internet tranquillamente; non è possibile sapere in quale parte del MENU dichiari con quale Annex stia funzionando; gli ho fatto un aggiornamento all'ultimo OS tedesco.

Problema:

1) accesso ftp con adam2 ma al comando:
quote SETENV annex,A
risponde
501 Syntax error invalid number of parameters

2) il recovery.image internazionale si conclude subito con la dichiarazione che il firmware è incompatibile con il recovery;

Come, secondo te, potrei procedere?
Grazie in anticipo per la collaborazione
reaudace
PrimoLivello
PrimoLivello
 
Messaggi: 5
Iscritto il: sab ago 02, 2014 10:21 pm
Ha ringraziato: 4 volte
Hai ringraziamenti: 0 volta

Messaggioda mipaneb » dom apr 09, 2017 8:01 pm

.
.
.

Premetto che non possiedo un 6840 LTE, quindi faccio dei ragionamenti che non posso verificare personalmente

Sulla base di quanto dici, non so che influenza possa avere il parametro Annex (caratteristico delle DSL) sul 6840 LTE, che tu stesso dici "funziona e si collega in internet tranquillamente"; la tecnologia LTE non ha nulla a che fare, che io sappia, con il mondo DSL ed i suoi ammennicoli; anche per questo motivo, probabilmente, non trovi nei vari menu l'impostazione Annex, come ho voluto velocemente provare anch'io cercando "annex" all'interno del manuale inglese del router:
https://en.avm.de/fileadmin/user_upload ... 40_LTE.pdf
(il manuale italiano non mi pare ancora disponibile)

Comunque, per non sapere nè leggere nè scrivere, per spirito sperimentale possiamo interrogare il router sulle attuali impostazioni, che probabilmente saranno quelle tipiche tedesche, soprattutto bisogna vedere se il numero di versione è inferiore o superiore a quella da inserire (cioè se hai a bordo il firmware tedesco xx.06.83, l'ultimo disponibile di marzo 2017, sarà impossibile che il recovery di versione precedente, cioè ad es. la xx.06.50 di marzo 2016, possa andare a buon fine)

Ciò è probabile se hai utilizzato il recovery internazionale che avevo linkato nel post precedente, ma nel frattempo è uscita anche la versione del recovery internazionale del 16 marzo 2017:
ftp://ftp.avm.de/fritz.box/fritzbox_684 ... -image.exe
... che avendo numerazione pari a quella che presumo installata, pure se in versione tedesca, consentirebbe di andare a buon fine



Quindi per passare da un firmware tedesco a quello internazionale la procedura è: immissione password e da FTP cambio variabile del brand, quote SETENV firmware_version avme seguito da quit e dal recovery internazionale; per eventuali "inferiorità" di recovery rispetto alla versione installata, occorre cambiare anche la variabile della versione, portandola ad un valore inferiore o pari a quella del recovery da utilizzare; in pratica, nel tuo caso, se volessi utilizzare il recovery xx.06.50 occorrerebbe impartire anche il comando quote SETENV firmware_info 105.06.50


Alcuni aspetti sintattici: dai messaggi ottenuti in risposta dal kernel linux del Fritz (con interfaccia BusyBox, varie versioni) si può facilmente evincere se la sintassi sia corretta; in linea di massima la virgola veniva adottata molti anni fa, vedo che tu hai riportato questa sintassi; ora si adotta lo spazio e l'uguale

Riprendendo le curiosità sperimentali, se vuoi potresti interrogare il Fritz da FTP:

quote GETENV annex
quote GETENV kernel_args annex

Dubito che le variabili suddette esistano; ove esistessero, potresti cambiarle in

quote SETENV annex=A oppure
quote SETENV annex A

quote SETENV kernel_args annex=A oppure
quote SETENV kernel_args annex A





Stay tuned
Michele


_______________________
Fritz!Box 7170v1 58.04.84 - Alice7M - ITU 992.1 - 8125/478 - s/n 18/20 - LA 25/23
Fonera - Speedport W701V - Fritz!Fon 7150 - SPA2102 - Zyxel 660HW61

per questo messaggio l’autore mipaneb ha ricevuto un ringraziamento da:
reaudace (lun apr 10, 2017 9:24 am)
Valutazione: 33.33%
 
Avatar utente
mipaneb
phpBB Moderator
phpBB Moderator
 
Messaggi: 4166
Iscritto il: mar ott 16, 2007 2:10 pm
Località: Monte Nieddu - Sardegna
Ha ringraziato: 22 volte
Hai ringraziamenti: 75 volte

Messaggioda reaudace » lun apr 10, 2017 9:46 am

Grazie 10.000

Riepilogo
6840 LTE anno di costruzione 2015 CAMBIO FIRMWARE DA TEDESCO AD ITALIANO
FRIT!BOX 6840 LTE NON COLLEGATO ALLA CORRENTE E CAVO DI RETE LAN SCOLLEGATO
IMPOSTAZIONI DI RETE
*Scheda di Rete del PC 192.168.178.10
*Gateway 192.168.179.1

Promt dei comandi
*ftp 192.168.178.1

Collegare IL CAVO DI RETE LAN al FB
Alimentare il FB 6840 LTE
Durante l'acquisizione della connessione LAN lanciare il comando ftp prima predisposto
Accedere alla connessione ftp con
*user_id adam2
°password adam2
Comandi successivi:
*quote SETENV annex A (se non lo accetta provare con annex,A oppure con annex=A)
*quote SETENV firmaware_version avme
*quit

Chiudere il prompt dei comandi.
Scollegare il FB dalla corrente elettrica.
Scaricare ed avviare il file fritz.box_6840_lte.en-de-es-it-fr-pl.06.83.recover-image.exe (o il ricover-image aggiornato all'ultima edizione)
Seguire le istruzioni dinamiche ricevute da MENU e ricollegare il FB quando richiesto dal programmino in esecuzione del recover-image. Se tutto va bene vi ritroverete con l'Assistente dl FB attivo. Cambiate la lingua, eventualmente anche la password e togliete la corrente al FB.

Il recover ormai è già terminato. Con la corrente tolta al FB inserire la SIM (dispongo di una SIM della TRE), ricollegate la corrente al FB, accedete al FB dalla sua interfaccia ecc.
Questo accesso è stato realizzato su rete WI-FI del 6840 LTE Italiano appena configurato.
reaudace
PrimoLivello
PrimoLivello
 
Messaggi: 5
Iscritto il: sab ago 02, 2014 10:21 pm
Ha ringraziato: 4 volte
Hai ringraziamenti: 0 volta


Torna a Firmware

Chi c’è in linea

Visitano il forum: Nessuno e 5 ospiti